Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
Welcome to the EGGhead Forum - a great place to visit and packed with tips and EGGspert advice! You can also join the conversation and get more information and amazing kamado recipes by following Big Green Egg at:

Facebook  |  Twitter  |  Instagram  |  Pinterest  |  Youtube  |  Vimeo
Share your photos by tagging us and using the hashtag #EGGhead4Life.


In Atlanta? Come visit Big Green Egg headquarters, including our retail showroom, the History of the EGG Museum and Culinary Center!  3786 DeKalb Technology Parkway, Atlanta, GA 30340.

Flame Boss 200 issue

I was cooking ribs yesterday, and noticed that my FB200 was acting kind of wonky every time I opened the dome. It would stay in OPEN mode and not get back to business unless I turned it off and on again.

Looked at their website to see if there was anything I should know and saw that the most recent firmware update (version 2.01) included a change to exactly what was troubling me. The other changes in the version are really nice (better display, etc.) but the change to the open pause setting didn't seem to work right.

So I contacted them and had an email response in less than an hour. They were monitoring and recording my cook to figure out what was wrong. A few more back and forth emails and by the end of the cook they agreed that something was wrong.

Another email from them today to let me know that it was a priority item for them to figure it out and fix it.

Just absolutely stellar customer service; I can't imagine better.
Cincinnati, Ohio. Large BGE since 2011. Still learning.

Comments

  • Photo EggPhoto Egg Posts: 7,903
    Agree completely, they are awesome people that stand behind their product.
    Thank you,
    Darian

    Galveston Texas
  • calikingcaliking Posts: 11,120
    Yep. They are some fine folks over there. They may even send you a new unit if they can't figure it out soon. 

    #1 LBGE December 2012 • #2 SBGE February  2013 • #3 Mini May 2013
    A happy BGE family in Houston, TX.
  • Can't say enough about thier customer service. They are one of the premier companies I have dealt with.

    Land of OZ-Central Kansas

    BGE XL with Flameboss 300 WiFi++Blackstone 36"+++Weber Smoky Joe++

  • Sonny3Sonny3 Posts: 454
    Thanks for posting about this issue.  I pulled out my FB200 to do some butts and when I plugged it in it upgraded to 2.01.01 software.  I had exactly the same problem with the fan not coming back on after a lid open pause.  Like you I resolved it by powering it down and up each time.  I also had to run through the different screens and change the temp by one degree up or down each time.  Then it would work great until the next time the dome was opened.

     I contacted FB and made them aware that I too was having the issue.  They are working on the software as fast as they can to fix it.

    Thanks again for posting,
    Sonny
    Titusville, Fl. and just bought XL and Med BGE.  "Every Day is A Bonus" in my world, and my job is to choke the life out of them. Cancer Sucks.
  • OhioEggerOhioEgger Posts: 461
    OP here again.
    I'm using the newest version of the firmware and the problem has been fixed nicely. They put the option back in to let you set the open pause delay time yourself and that did the trick.
    Cincinnati, Ohio. Large BGE since 2011. Still learning.
  • 2.01 had some issues, and yes...it didn't take but a few days for them to download 2.04 to my controller.  Everything works good again, and the fan delay is back to where it worked best. 

    Land of OZ-Central Kansas

    BGE XL with Flameboss 300 WiFi++Blackstone 36"+++Weber Smoky Joe++

Sign In or Register to comment.
Click here for Forum Use Guidelines.