Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
Welcome to the EGGhead Forum - a great place to visit and packed with tips and EGGspert advice! You can also join the conversation and get more information and amazing kamado recipes by following Big Green Egg at:

Facebook  |  Twitter  |  Instagram  |  Pinterest  |  Youtube  |  Vimeo
Share your photos by tagging us and using the hashtag #EGGhead4Life.


In Atlanta? Come visit Big Green Egg headquarters, including our retail showroom, the History of the EGG Museum and Culinary Center!  3786 DeKalb Technology Parkway, Atlanta, GA 30340.

XL hinge question

dhuffjrdhuffjr Posts: 3,182
edited 1:48PM in EggHead Forum
Does this look right?
IMG957697.jpg

Comments

  • CobraCobra Posts: 110
    From what I can see, it looks the same as mine.

    Whats the issue?
  • Looks mightyfine - here is mine

    101_1738640x480.jpg
  • "Sparky""Sparky" Posts: 6,024
    Looks right to me

    001-16.jpg

    002-14.jpg
  • eenie meenieeenie meenie Posts: 4,393
    Dennis, thanks for looking into this matter. :)
  • dhuffjrdhuffjr Posts: 3,182
    It may look right......but seriously..... it don't feel right.....we'll get to the bottom of this. We might have to arrange an Eggervention to cure its ails.
  • eenie meenieeenie meenie Posts: 4,393
    I agree, it doesn't feel right, it has a 'glitch' when lifting.
  • dhuffjrdhuffjr Posts: 3,182
    Does it have a fascination with red staplers?
  • Photo EggPhoto Egg Posts: 7,814
    Check this bolt. I had to grind mine down so it would not bind into the band.
    I have seen it happen to many XL users.
    When it binds it will give you a very funny feeling when lifting.
    One bolt on each side. Look for a rub marks on you band from the bolt.
    Hope this helps.

    xl.jpg
    Thank you,
    Darian

    Galveston Texas
  • funk49funk49 Posts: 115
    Photo Egg wrote:
    Check this bolt. I had to grind mine down so it would not bind into the band.
    I have seen it happen to many XL users.
    When it binds it will give you a very funny feeling when lifting.
    One bolt on each side. Look for a rub marks on you band from the bolt.
    Hope this helps.

    xl.jpg
    I had the same problem. What I did was to remove the springs and loosen up the band . I turned the bolt around so the nut is on the outside. That fixed it. :)
  • Photo EggPhoto Egg Posts: 7,814
    Good option as well if you don't have a grinder.
    Did not want the bolt end sticking out and snagging my cover so I just ground off 1/4".
    Thank you,
    Darian

    Galveston Texas
  • dhuffjrdhuffjr Posts: 3,182
    That may be it. The authority on the subject hopefully will chime in later.
Sign In or Register to comment.
Click here for Forum Use Guidelines.