Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Friends

Followed by 7 people
RICHIED777
Rplatt2
Monty77
We hope everyone’s enjoying the first few days of summer. For us, the weather heating up means one thing - the EGG’s gonna be busy! Whether you’re making stuffed burgers for a backyard grill out, some brats before a baseball game or searing a steak for dinner on the patio, we hope you’re doing it with full flavor and having fun all the while!

Big Green Egg headquarters has moved - come visit our new showroom and check out the museum and culinary center too! 3786 DeKalb Technology Parkway, Atlanta, GA 30340

The Naked Whiz

About

Username
The Naked Whiz
Joined
-
Visits
2,624
Last Active
Roles
Member
Points
202
Posts
7,780

Activity

  • mcmac
    Hey Whiz,

    Just wanted to send you a quick thank you for your config information on the Stoker BBQ unit. I was able to follow the information you provided to make the installation for the Wifi much easier. 
    I now have it up and running and can access remotely via the StokeMaster app for iPhone.

    Thanks again my friend.

    Mike
    ·
    July 2014
  • lgd4ua
    What size Rutland Gasket should I use on XL Green Egg?
    ·
    June 2013
  • bigearl
    Did your spatch cooked chicken- incredibly moist, but a little bland. I coated both sides with our favorite rub. Any suggestions? Would an injection work?
    ·
    January 2012
  • Iceman5705
    I can't seem to be able to post. The box is there but when I try to click in it it won't give me a cursor to type. In other words, I can't start a new discussion??
    ·
    September 2011
  • sidedish
    Whiz - I am fairly new to the Egg world, I just cooked some Peppers and when I opened the lid of the Egg there was what appeared to be a white frost over everything except the food. The temp was around 400, using Weekend Warrior with a plate setter. Any Ideas?
    ·
    August 2011
  • sidedish
    Whiz - I am fairly new to the Egg world, I just cooked some Peppers and when I opened the lid of the Egg there was what appeared to be a white frost over everything except the food. The temp was around 400, using Weekend Warrior with a plate setter. Any Ideas?
    ·
    August 2011
  • hvoss
    When I open lid to put food in, the temp drops way down for a few minutes. We did steaks last night and we wanted to cook 2 minutes, turn over, 2 minutes turn over again and then shut off and leave steaks in for 2 more minutes. That is what the video said to do (BGE) but each time we oped lid, temp dropped way down so how could we cook 2 more minutes each time since it wasn't the proper temp for at least 3 minutes. I am NOT giving up, but getting frustrated.
    ·
    August 2011
  • Dimple's Mom
    Is the old forum gone completely or is there some way to get to it? Thanks, Gwen (dimplesmom) gwenb@whidbey.com
    ·
    August 2011