Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
It’s that time of year again-time to hop on out to your backyard for an EGG hunt. If you’re lucky, you’ll only have to search as far as your patio! Planning on cooking Easter Sunday? Check out our Easter Menu. If you’re looking for a sweet treat to enjoy with the whole family, try at least one of our sweet treats, if not both: Grilled Peeps & Carrot Cupcakes. Lastly, if you’re having company, our Pinterest page has lots of ideas for entertaining. We hope you have an EGGstra tasty holiday!



The Big Green Egg headquarters has moved - come visit our new location and check out the museum! 3786 DeKalb Technology Parkway, Atlanta, GA 30340

Maverick ET-732

'Most' of the time, my Maverick ET-732 works great. But more likely, the meat probe reading stay HHH. Except when I'm grilling a steak, I never get above 300 degrees. What am I doing wrong?
·

Comments

  • henapplehenapple Posts: 13,527
    My grill probe just went out. Is yours dirty? Might clean it.
    Green egg, dead animal and alcohol. The "Boro".. TN 
    ·
  • SkiddymarkerSkiddymarker Posts: 6,458
    With the "always when you don't want to see it" LLL or HHH, I suggest shutting off the units and reseating the probe plugs in the transmitter. Turn them back on, receiver first. Mine seems to like this method of tender care.
    Delta B.C. - Vee-Gan: old Indian word for poor hunter. 
    ·
  • jscarfojscarfo Posts: 398
    I thought HHH ment the probe is ruined?
    ·
  • gerhardkgerhardk Posts: 812
    edited January 2013
    I think when you see that it is above the highest rated reading, somewhere around 600ºF.  I only use mine to monitor low and slow cooks when I am grilling not really that concerned with temperature.

    Gerhard
    ·
  • dlk7dlk7 Posts: 994
    When I get any error with my 732, I shut if off, switch the probes into the opposite ports, set the temps again, resync, turn it off and put the probes back in the correct port, and restart.  Not sure why, but it has always fixed any error I've had.  Maybe just lucky.

    Two XL BGEs - So Happy!!!!

    Waunakee, WI

    ·
  • calikingcaliking Posts: 6,585
    gerhardk said:

    I think when you see that it is above the highest rated reading, somewhere around 600ºF.  I only use mine to monitor low and slow cooks when I am grilling not really that concerned with temperature.


    Gerhard
    I think the standard probes may not go as high as 600. I think they read HHH at 470ish. There are high temp probes available for the maverick which go higher. This was at least true for the et73. Make sure you don't submerge the probes when cleaning as they can be delicate if the connection between probe and wire gets wet.

    #1 LBGE December 2012 • #2 SBGE February  2013 • #3 Mini May 2013
    A happy BGE family in Houston, TX.
    ·
  • Ditto on high temp cooks
    Lovin' my Large Egg since May 2012 (Richmond, VA) ... and makin' cookbooks at http://familycookbookproject.com
    ·
  • bud812bud812 Posts: 1,329
    When mine said HHH the porbe wasn't pluged in far enough. When it said LLL the probe was bad.

    Not to get technical, but according to chemistry alcohol is a solution...

    Large & Small BGE

    Stockton Ca.

    ·
  • atbarratbarr Posts: 26
    Like I said, I never smoke above 300 degrees. I had wash, the cable has never got wet. Is there another brand I should look at? It's pretty hard trying to smoke without being able to check the internal temp.
    ·
  • gerhardkgerhardk Posts: 812
    When you route the probe wire make sure that it is protected by one of the platesetter's legs, for extra protection wrap the probe's wire with tin foil.  

    Gerhard
    ·
  • atbarr said:
    'Most' of the time, my Maverick ET-732 works great. But more likely, the meat probe reading stay HHH. Except when I'm grilling a steak, I never get above 300 degrees. What am I doing wrong?
    Very often, when I start my cook, my ET-732 shows the HHH.  (usually on the grill temp). I push the two sensor wire plugs into the transmitter very hard and it usually starts working correctly.

    Mudpuppy45 (Ten Miles North of the Gulf in Alabama) Large BGE
    ·
  • atbarratbarr Posts: 26
    " It's pretty hard trying to smoke without being able to check the internal temp."

    Sorry, you guys know that.
    ·
  • atbarratbarr Posts: 26
    So I wanted to smoke a Prime Rib Roast. The meat probe was dead. Duh! The battery was dead. I installed a new battery, and it worked perfectly. Life is Good, and so was the Prime Rib Roast.
    ·
Sign In or Register to comment.