Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
Welcome to the EGGhead Forum - a great place to visit and packed with tips and EGGspert advice! You can also join the conversation and get more information and amazing kamado recipes by following Big Green Egg at:

Facebook  |  Twitter  |  Instagram  |  Pinterest  |  Youtube  |  Vimeo
Share your photos by tagging us and using the hashtag #EGGhead4Life.


In Atlanta? Come visit Big Green Egg headquarters, including our retail showroom, the History of the EGG Museum and Culinary Center!  3786 DeKalb Technology Parkway, Atlanta, GA 30340.

SLOW cooking Pulled Pork

Eggin-smurffEggin-smurff Posts: 31
edited 5:47AM in EggHead Forum
Hi folks and Happy Memorial Day,

I've done pulled pork many times over the years but this weekends cook completely baffles me!!!

I did everything as I normally do, started with a clean egg, filled with a fresh bag of just opened BGE lump, hickory chunks for smoke, platesetter legs up, drip pan on that filled with apple juice, grid with two 8lb. shoulders preped with mustard and rub, BBQ Guru set to 225 grid and shows 250 dome and it's been rock solid.

The problems is, I put the meat on at 4:30pm yesterday and the meat is only up to 185. Almost 21 hours now!!! In the past, I've pulled the meat at 200 at around 15~16 hours. I've double checked the meat temp with my Thermopen to insure it not a faulty guru reading.

What's different this time? The only thing I can think of is that these shoulders were frozen but completely thawed before going on the egg.

Hmmmm

Comments

  • RascalRascal Posts: 3,643
    Where are you located? Murphy's spent some time around here today!! 8 - )
  • ForniaFornia Posts: 451
    I'm doing the same thing right now...for the very first time. The only thing I did different was I injected.

    I have (2) roughly 7.25# butts in there on 250...it's now been almost 15 hours and the internal is stuck on 188.

    I know there is a 'stall' with temp, but I thought that was around 180.

    I'm sure there is no 'given'...but there has to be some window. We're learning!
Sign In or Register to comment.
Click here for Forum Use Guidelines.