Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
There are two very delicious food holidays coming up that we wanted to share with you all because cheese and guac deserve to be celebrated! Guacamole Day is on September 16th and Cheeseburger Day is on September 18th. Happy cooking EGGheads! It's time to think about getting out to one of the many #EGGfests around the country - see a list here

Cyberq Wifi connection help

sjg34sjg34 Posts: 22
edited June 2012 in EggHead Forum
I'm unable to connect to the cyberq unit in adhoc mode.  The pc shows a connection but I do not recieve any packets.  Can anyone offer any advise?
«1

Comments

  • Rich_ieRich_ie Posts: 268
    Dont have one someone will post soon. 
  • I do not have one but basic trouble shooting would be to evaluate if it received an IP address (or is it statically assigned).  Do all of your subnets match?  IP range etc?  Do you have another wireless network it can join off of a WAP?
  • sjg34sjg34 Posts: 22
    I started an old Dell laptop that I have and it connects without any issues.  the Dell uses windows xp and my other laptop is windows 7.  I noticed my tablet doesn't see the ssid.  Any ideas why only the xp pc would work?.
    the ip is static.  
  • RekxRekx Posts: 9
    yeah same thing is happening to me - I am on a mac and firefox.   Can't figure this damned thing out.  The BBQ Guru instruction manual does not help very much at all.  I'm looking forward to seeing if anyone has advice.
  • First off: have you tried resetting the device? hold down all the arrow keys for 5 seconds and you'll see it flash on the screen. It'll say something like 'Resetting EEPROM'.

    In adhoc mode you will FIRST need to after powering on the CyberQ to click on your 'bars' for your local network that your computer sees. You should see the CyberQ as a device that you can connect to. When you do select it you'll want to input the default password: 1234abcdef

    After connecting to the device (just like you'd select a new wireless network in Starbucks or any free Public WiFi), open your browser of choice and browse to the CyberQ default IP address in the browser address bar: 192.168.101.10

    That's it. Let me know if y'all have any other questions. And NO, I don't work for them. I just happened to have just bought a CyberQ this week and I'm getting mine setup for a low and slow cook tomorrow!
  • GadflyGadfly Posts: 114

    Not every device supports wireless adhoc mode. Many phones or tablets do not support wireless adhoc mode (and unfortunately infrastructure mode is not 'officially' supported either. Windows 7 however should work just fine.

    Your PC should show the cyberq as an available wireless network. once you click on the network and choose to connect to it, it should prompt you for the password. Do you get this far?

    I could never get it to work in infrastructure mode (it seems to be picky about access points and -apparently- works with the old ones but not new ones) but connecting in adhoc mode (Windows 7) has never been a problem. Unfortunately that's not good enough for me.

  • sjg34sjg34 Posts: 22

    Not every device supports wireless adhoc mode. Many phones or tablets do not support wireless adhoc mode (and unfortunately infrastructure mode is not 'officially' supported either. Windows 7 however should work just fine.

    Your PC should show the cyberq as an available wireless network. once you click on the network and choose to connect to it, it should prompt you for the password. Do you get this far?

    I could never get it to work in infrastructure mode (it seems to be picky about access points and -apparently- works with the old ones but not new ones) but connecting in adhoc mode (Windows 7) has never been a problem. Unfortunately that's not good enough for me.

    I was able to get the infrastructure mode work without much effort once I was able to connect with the XP laptop in adhoc.  I have a year old netgear router and if you have something similar and I might be able to send you what I did. Let me know.
    I started a pork butt last night and the controller appears to be working great

  • sjg34sjg34 Posts: 22
    yeah same thing is happening to me - I am on a mac and firefox.   Can't figure this damned thing out.  The BBQ Guru instruction manual does not help very much at all.  I'm looking forward to seeing if anyone has advice.
    Do you know anyone that has another laptop you could try? My windows 7 pc would show I was connected but it would never receive any packets.  
    You might be able to skip adhoc and go straight for the infrastructure.  I think all of the required changes you can do from the cyberq itself.  Although it would be a PIA to use the arrows to change the settings.
    I found a troubleshooting guide on BBQ Guru, here is a link.  Not much help either
  • The Naked WhizThe Naked Whiz Posts: 7,778
    Just to make you feel bad ;) I had no problem at all connecting in either mode with Windows 7 and Windows Vista. 

    I don't understand the comment about not all devices supporting ad hoc mode.  Isn't the CyberQ (when in ad hoc mode) just like any other network that you might find when you list available networks?  What's the difference between connecting to the CyberQ and connecting to my router's network or my neighbor's networks?

    The Naked Whiz
  • RekxRekx Posts: 9
    yeah I am properly connected in ad hoc mode, but the "main screen" does not show any data.  When I make changes to the "control" screen I can see it send the data and the changes are reflected on the unit, but again nothing on the "main" screen.  When I make changes in the "main" screen it does not do anything.  That's to say, it doesn't say "transferring data to 192.168.101.10" at the bottom of my screen.  So I don't know what the heck.  I guess I will call bbq guru or send an email on monday.

    In a separate question - is there any way to get the temp data for graphs?  I thought I saw people with nice graph screens?  Or is that another device.  I would really like a nice graph.
  • JWBurnsJWBurns Posts: 334
    Are you guys able to change / monitor temps from your smartphone? If so, how? Is there an app?
  • RekxRekx Posts: 9
    no app....supposedly you can monitor and change from a smartphone.
  • I have mine working with Windoze XP/7 and Linux and 4 different access points from an old WRT54G to a new Cisco EA4500.  The CyberQ is a G mode only device, you may experience issues with some multiband a/g/n routers that are either configured to N mode only or have issues with mix mode operation.  It looks fine on an AirMagnet Wifi Analyzer, so I can't see any way that the older access points would be any more likely to work than the newer ones, with the exception of the available security and band mode settings in the newer devices causing configuration issues.  When you power up the CyberQ, be aware that it may intially say that it has no network, but in reality it is performing the security handshake which is particularly slow if you have it set to WPA.  If you have't given it a minute or so to connect, you will think it isn't working but it is.  If left alone a sufficient amount of time, the keys will light up and flash when the handshaking is done.  If the web pages aren't functional, then you likely have scripting disabled in your browser or heaven forbid you would be using IE, you need to check your security "zone" settings and make sure that scripting is allowed.  I don't work for BBQ Guru, but I am a embedded system design consultant and build wifi enabled appliances for my customers on a regular basis.  I am happy to help anyone troubleshoot their device if desired - just PM me here.
  • sjg34sjg34 Posts: 22
    Some people are working on apps for the cyberq, here is a link the the thread.
    They have a windows based prototype posted for download
  • RekxRekx Posts: 9
    omg that image is friggin sick!!  want!
  • The Naked WhizThe Naked Whiz Posts: 7,778
    jwburns you can always use just a browser on your smart phone to control the CyberQ Wifi.
    The Naked Whiz
  • JWBurnsJWBurns Posts: 334
    jwburns you can always use just a browser on your smart phone to control the CyberQ Wifi.
    Thanks Whiz

  • The Naked WhizThe Naked Whiz Posts: 7,778
    Some people are working on apps for the cyberq, here is a link the the thread.
    They have a windows based prototype posted for download
    I can't get it to install.  It tells me I need to be an administrator, but of course, I am one.  I even tried creating a new admin account and it fails there too.  Anyone had any luck?
    The Naked Whiz
  • sjg34sjg34 Posts: 22

    Mine runs fine.  I didn't see anything about being an administrator.  Did you download both files?
    Not to make you feel bad :)
  • sjg34sjg34 Posts: 22
    Is it the Microsoft dotnet programe that give you the message about not being an administrator? 
  • The Naked WhizThe Naked Whiz Posts: 7,778
    edited July 2012
    The dot net installed fine.  It's the application that gives error 1303, I don't have permission to access file c:\program files\blah blah blah.

    This is on Windows 7, fwiw


    The Naked Whiz
  • sjg34sjg34 Posts: 22
    I'm running it on a windows 7 64 bit laptop
  • sjg34sjg34 Posts: 22
    You might try and post a question to the forum in the first link above
  • North_Is_UpNorth_Is_Up Posts: 119
    Naked Whiz: When you try to install, right-click on the file and choose run as Administrator. 
    XL BGE w/CyberQ Wifi, KCBS CTC CBJ
  • The Naked WhizThe Naked Whiz Posts: 7,778
    North, thank you!  I vaguely sort of knew that from some past experience, lol.  All is well now.....
    The Naked Whiz
  • North_Is_UpNorth_Is_Up Posts: 119

    Some users, myself included, have had problems with Infrastructure mode. I solved mine by using an older access point. I'm pretty good at networking, but I just couldn't make it work with my router directly. No problem with the access point. Made me feel good because I thought I had a defective unit. It's only partially defective.

    I'm not saying an older unit is any different than the new one, I'm just saying that full handshaking did not take place. The CyberQ Wifi got an IP and proper DNS and gw settings from my router. It wouldn't PING, as an example, so I was never going to get a web page delivered from it with IE or Chrome. When I put the access point into the mix, the CyberQ Wifi connected immediately. It still gets it's IP,etc., from the router, it just doesn't talk directly to the router, but through the access point on the network, instead. I've rebooted everything and tried all of the possible combinations of security, but it just doesn't work with my router. Others have had problems with this model of Netgear (WNDR3700), too. I don't do comps, so I have no need for Ad hoc mode, but I fully trust sjg34 saying that it's not working correctly. No surprise. It must be slightly out of spec, so it works with certain units and not fully with others.

    So, the CyberQ Wifi seems buggy to me. Mine boots with 0.8 firmware, not 1.0 as in the owner's manual. Does anyone have a later version? I also don't see a way to ever upgrade the firmware, but maybe something is hidden?

    XL BGE w/CyberQ Wifi, KCBS CTC CBJ
  • sjg34sjg34 Posts: 22
    the firmware update is done using a dos window, butI haven't been able to find an update posted anywhere.
    i was able to get it to connect to the wndr3700.  I can take some screenshots of what I changed if you would like.
  • North_Is_UpNorth_Is_Up Posts: 119

    Please just tell me what you changed, if you don't mind. I won't need screen shots. Are you on 0.8 firmware, too?

    Thank you

    XL BGE w/CyberQ Wifi, KCBS CTC CBJ
  • sjg34sjg34 Posts: 22
    North_Is_Up

    My firmware is 0.8

    This is what I did after I set the infrastructure on, DHCP on, SSID, and the wpa2 password.  When I first entered the password it didn't work because I had WPA2 selected and not WPA2 phrase selected

    In the router go to the advance tab, administration, attached devices, and find the cyberq under wireless devices area and get the ip address.  Note this was different than what was assigned previously to the internal menus of the cyberq, mine was 192.168.13
    On the advanced tab, advanced setup, port forwarding / port triggering.  I added a new port forwarding service using http service and the ip address of the cyberq (192.168.1.13), using port 80.
    Once this was done I was able to enter 192.168.1.13 and access the cyberq.

    Hope it helps
Sign In or Register to comment.