Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
Welcome to the EGGhead Forum - a great place to visit and packed with tips and EGGspert advice! You can also join the conversation and get more information and amazing kamado recipes by following Big Green Egg at:

Facebook  |  Twitter  |  Instagram  |  Pinterest  |  Youtube  |  Vimeo
Share your photos by tagging us and using the hashtag #EGGhead4Life.


In Atlanta? Come visit Big Green Egg headquarters, including our retail showroom, the History of the EGG Museum and Culinary Center!  3786 DeKalb Technology Parkway, Atlanta, GA 30340.

Polder

DaleDale Posts: 41
edited 3:50AM in EggHead Forum
I just had my second Polder oven thermometer break in the past few months. Is there a problem with these? Are there better alternatives or am I just unlucky?

I have not exposed either one to excessive heat BTW....

Thanks,
Dale

Comments

  • Did the unit break or did the probe go bad?
    The Naked Whiz
  • DaleDale Posts: 41
    Not sure, the temp reads something around 250 at room temp. Is that the probe? Only the in food display, the oven display seems OK.
  • Celtic WolfCeltic Wolf Posts: 9,773
    Switch the probes. If you still get the same readings it the Polder. If the reading switch too it's the probe.

    Getting the probes wires wet will ruin them too
  • RRPRRP Posts: 19,522
    not quite following you here when you said "Only the in food display, the oven display seems OK" do you have a 2 probe Polder which it sounds like. Meat = "in food" and then "oven display" = grate temperature?
    Also do you wrap your probe wire(s)? While people debate wrapping and not wrapping I have wrapped my metal mesh probes for years and they have lasted for years! Otherwise the smoke and grease gunk up those metal cables making them stiff and brittle. After all - the two wires inside that cable are tiny and delicate - not jumper cables for your car.
    L, M, S, Mini
    Ron
    Dunlap, IL
  • DaleDale Posts: 41
    The model Polder I have, has two sensor in the probe. One in the tip for food and one in the base to measure the oven temp. It came from Sur la Table. It is the second one to go. I see there is an expensive one, $19 on Thermoworks. I guess I'll order a few.
  • MattMatt Posts: 143
    Wow, I've had the same dual-sensor Polder for about five years now. I've never wrapped the wire and the last time I checked the readings, I got 211 on one sensor and 213 on another when submerged in boiling water. I wish all of my purchases worked out as well as my Polder. Sorry to hear you're having problems.
  • Contact Polder's customer service department.
    I had a problem with mine reading WAY high and they sent me a new probe, no charge. Works perfect now.
Sign In or Register to comment.
Click here for Forum Use Guidelines.