Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
Welcome to the EGGhead Forum - a great place to visit and packed with tips and EGGspert advice! You can also join the conversation and get more information and amazing kamado recipes by following Big Green Egg at:

Facebook  |  Twitter  |  Instagram  |  Pinterest  |  Youtube  |  Vimeo
Share your photos by tagging us and using the hashtag #EGGhead4Life.


In Atlanta? Come visit Big Green Egg headquarters, including our retail showroom, the History of the EGG Museum and Culinary Center!  3786 DeKalb Technology Parkway, Atlanta, GA 30340.

Threads w/lots of photos slow to load

WileECoyoteWileECoyote Posts: 516
edited 10:15AM in Forum Feedback
I noticed that any threads which contain more than a few photos will take a long while to load. Anywhere from 5-30 seconds after you first click on the thread title. The delay is longer when there are more pics. On other forums the text of the thread will load instantly and you can read it while the photos finish loading. Why is it different on this forum, and is there a way around it? I host my own photos and have confirmed that the same photos load faster on other forums so I don't think it is my photo host. I also make sure to set the IMG tag with the correct size when submitting the post, keep all photos as 600x400 or similar, and usually 75 DPI / 250kb or less. What am I missing?

Comments

  • EggtuckyEggtucky Posts: 2,746
    Have noticed the same WileE..sorry to say sometimes it's not even just the posts with photos..I've been clipping along reading post replies and suddenly click on one with nothing but a text response and the site will hang there until I click the 'X' to stop loading and then re-click the reply...borked
  • WMKWMK Posts: 1,747
    WileECoyote,

    We have a couple of issues with images. I think we'll soon remove the code that attempts to determine the image size -- that is probably the slow down. It does sometimes hang on non-image files and other cases as well. Currently we are working on Eggtoberfest; so, we won't have time to fix it immediately, but now that the new search is deployed (have you tried it?), image issues are next on our list.
  • WileECoyoteWileECoyote Posts: 516
    Thanks WMK.

    I will anxiously await the removal of the code which slows down the photo threads. I noticed that it doesn't always get the image sizes right anyway so I am careful to manually size each of my links when inserted.

    I did try the new search recently and it looks a LOT better than the old search. I really like the options and how it shows the score. I didn't test it extensively but here are a few comments:

    - most results appeared to be displayed as threads which was nice but some threads were still repeated twice, would be ideal for the user to have the option to show results by thread or by post

    - can we search for the threads or posts started by a particular user?

    - many pages have more than 1 search box on them now (top right forum header and mid-left content section), be best to have only one search box in the same location on all pages

    - neither search box has a GO button or similar link next to it, so which terms are used for the search if both fields contain something and the user presses the ENTER key?

    - some pages still don't have the search box (I think)

    On an unrelated note: many pages in the forum do not have a link to post a new thread. I end up having to read a specific post to get to the link to post a new thread.

    One last thing: it would be nice to have a link next to each user's avatar, signature, or photo to contact them via PM. So many people post threads with "PING Sam Smith" or whatever and this seems horribly ineffieicnt. I assume that most of them do not know how to easily send private messages via the forum.
  • WMKWMK Posts: 1,747
    WileECoyote,

    The default options search only thread titles, but once the initial search is done users can select to search replies as well as the message body.

    There is a user search but there appears to be no way to invoke it. We will look into this after Eggtoberfest registrations are ready. That is our priority at the moment.

    The two search boxes are different. There is more than a forum on this site. The box at the upper right is a "site search". It includes the recipes section, the forum, and other content as well. At the moment, there is limited content besides the forum and recipes, but that may change in the future. We may allow members to submit content like a Wiki (there are Wiki components for Mambo). The site search does not show all results for the forum (because there are often way too many); and, it does not provide the extended options that the forum search does. We'll look into clarifying things perhaps. The site search comes with Mambo and we've added the forum and recipes to the usual content search.

    The new forum search is based on a completely different principle than the old one (or phpBB). It uses a "fulltext" index to allow all 350,000 messages to be searched very quickly; and, supports various "advanced" options covered in the FAQ. For example the search link below finds threads about "XL vs LG" spelled various ways:

    http://www.eggheadforum.com/index.php?searchword=XL+%2B%28LG+large%29&boolsearch=1&option=com_simpleboard&Itemid=112&func=search

    There is a "Search" button at the bottom of the advanced form. Well look into adding a "Go" button, or the like, on all of the pages. That might indeed make things clearer. That's just not the way it came.
Sign In or Register to comment.
Click here for Forum Use Guidelines.