Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
Welcome to the EGGhead Forum - a great place to visit and packed with tips and EGGspert advice! You can also join the conversation and get more information and amazing kamado recipes by following Big Green Egg at:

Facebook  |  Twitter  |  Instagram  |  Pinterest  |  Youtube  |  Vimeo
Share your photos by tagging us and using the hashtag #EGGhead4Life.


In Atlanta? Come visit Big Green Egg headquarters, including our retail showroom, the History of the EGG Museum and Culinary Center!  3786 DeKalb Technology Parkway, Atlanta, GA 30340.

Pork butt/Maverick

GatoGato Posts: 766
edited January 2012 in EggHead Forum
Was up early this morning and put on a 5 pound pork butt rubbed with mustard and dizzy dust. The egg is working flawlessly and holding temp right at 255 or so with the grate temp at 235 right now. Meat has been on five hours and is at 155. My maverick has been losing signal from time to time which is annoying. It's only about 30 feet from the transmitter separated by a window. Anyone else have this problem?
Geaux Tigers!!!

Comments

  • IrishDevlIrishDevl Posts: 1,390
    The last time I used my Maverick I had that issue.  A few days ago I lost the temp on ribs I was cooking.  Lost signal, but always came back on.  I assume something just interfering with the signal.
  • GatoGato Posts: 766
    Yes, it regains the signal on it's own. It would be a problem if it was overnight and trying to sleep. Was wondering if it could be the wifi in the house???
    Geaux Tigers!!!
  • SqueezySqueezy Posts: 1,102
    Are you referring to the ET-73? If so, I had a constant problem getting a signal in the house. The new ET-732 works great anywhere in the house for me.
    Never eat anything passed through a window unless you're a seagull ... BGE Lg.
  • IrishDevlIrishDevl Posts: 1,390
    I have the ET-732 and only had the issue once.  It could be the wifi I suppose, could be something from the neighbors.  Phones.  Maybe batteries need to be changed.  
  • GatoGato Posts: 766
    No, it is a new 732, second cook with it. First cook, no problem. Emailed maverick.
    Geaux Tigers!!!
  • GatoGato Posts: 766
    The back yard is smelling great. Temp creeping up a little on the dome. Bottom and top vents almost closed.
    Geaux Tigers!!!
  • GatoGato Posts: 766
    Haven't taken a look. Meat probe at 187. Should I check it at all, or just let it go to 200?
    Geaux Tigers!!!
  • "Should I check it at all, or just let it go to 200?"

    Lookin' ain't cookin'.

    My actuary says I'm dead.
  • let it go!

    Large BGE Dyersburg TN
  • gerhardkgerhardk Posts: 938
    Patience is a virtue. I have ribs going right now should be ready in an hour.

    Gerhard
  • GatoGato Posts: 766
    Come on give me a little credit, I haven't opened it in 10 hours.
    Geaux Tigers!!!
  • gerhardkgerhardk Posts: 938
    Just sauced the ribs and my patience is running low.

    image
  • GatoGato Posts: 766
    Those look great, wish I knew what mine looked like. Stuck at 187°
    Geaux Tigers!!!
  • GatoGato Posts: 766
    Well after 12.5 hours for a five pound butt, it finally hit 200. Only had time for an hour in the cooler. It turned out really good, especially with the bbq sauce my daughter and I made up. My wife loved it. I have to admit I thought it would have been a little more moist and I think we will add some liquid when we reheat tomorrow. Do any of you wrap in foil towards the end or inject any liquid? All in all a successful cook. Thanks to all for the advice and hints I have read on this forum in the past couple months.
    Geaux Tigers!!!
Sign In or Register to comment.
Click here for Forum Use Guidelines.