Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
Avatar

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Friends

Followed by 1 person
Welcome to the EGGhead Forum - a great place to visit and packed with tips and EGGspert advice! You can also join the conversation and get more information and amazing kamado recipes by following Big Green Egg at:

Facebook  |  Twitter  |  Instagram  |  Pinterest  |  Youtube  |  Vimeo
Share your photos by tagging us and using the hashtag #EGGhead4Life.


In Atlanta? Come visit Big Green Egg headquarters, including our retail showroom, the History of the EGG Museum and Culinary Center!  3786 DeKalb Technology Parkway, Atlanta, GA 30340.

Trek660

About

Username
Trek660
Joined
-
Visits
0
Last Active
Roles
Member
Posts
14

Comments

  • Chrono, It's been holding a little under 250 steady for the last 3 hours. Whew. Yep. It's just like what you were talking about the first 20 minutes. I'll just close it down a little quicker. Next time.
  • Thanks for the link. It did not reach much over 300 before I tried to lower it. It just seems to take forever to get it back down without completely choking it out. That happened to me the last time. I was able to restart the fire without having to …
  • Thanks to everyone for the response and answers. Lee
  • Thanks for the help. I guess I just keep using too little lump. If ever I should have to add more lump during a low and slow smoke. Only solution is to remove grill and grub and add coal then place grill and grub back?? Thanks
  • Try these pics one more time. [img size=387][/img]
  • Try to get the pics one more time.
  • Try to upload an image again
  • Thanks, That is probably the problem. Everything is in proper alignment as fire as the firebox and bottom vent. I can't think of anythig else. I did use very little lump coal. I 'll be sure to add more the next time I cook. Also, one other question.…
  • I don't think I had too much lump. Used Green Egg lump coal. Original level was even with holes so i don't think that should have been to much. Can't see where anything was restricting airflow especially since it really took off to begin with and th…
  • Yes , this was my first cook. Everything in alignment. When I originally started the coals the temp went to about 400 or higher pretty darn quick. I was able to stabilize at 300 to cook the salmon. That is why i was concerned about the drop in temp…
Click here for Forum Use Guidelines.