Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
We hope everyone’s enjoying the first few days of summer. For us, the weather heating up means one thing - the EGG’s gonna be busy! Whether you’re making stuffed burgers for a backyard grill out, some brats before a baseball game or searing a steak for dinner on the patio, we hope you’re doing it with full flavor and having fun all the while!

Big Green Egg headquarters has moved - come visit our new showroom and check out the museum and culinary center too! 3786 DeKalb Technology Parkway, Atlanta, GA 30340

Guru fan problem

James MBJames MB Posts: 349
edited 1:35PM in EggHead Forum
I have a problem with my fan which is part of a brand new DigiQII setup.
I am in the UK.

Every so often it won't work - the blower light comes on on the controller but the fan doesn't operate.

It seems the fan has a number of natural "park" positions that it comes to rest at and that sometimes it comes to rest at one from which it can't restart, if you spin the fan from here it carries on happilly. I tried running it continuously for half an hour to break it in and the problem seemed to go away.
I put the overnight cook on and came down in the morning to find the temp low, the control saying it was blowing 100% but the fan stalled.
I gave the fan a spin and off we went. I repeated as (infrequently) necessary during the day.

You'll appreciate that having a dodgy fan reduces the reliability of the whole unit so I'm keen to find a solution.

I tried to recreate the condition by finding the natural park positions and trying a start from rest at each of them (I put a marker pen mark on the fan to keep track).

Initially it seemed the fan had five natural rest positions. This seemed pretty odd as I've no Idea how these things are wound but I would expect an even number. It seems the positions are at the four compass points with one extra between two of them.
The extra one is the one that stalls it.

I have tried a bit of continuous running to wear it in but you'll appreciate how hard it is to determine whether I've done the job. This fifth parking point seems to have diminished, hence diminishing the likelihood of coming to rest in the stall position.

I've tried a couple of emails to their customer service but to no avail, I'm on the other side of the Atlantic so shipping is probably more than the unit.

This brings me to raise the following:

1. Anyone else have an issue like this?

2. If I want to try and lubricate the fan bearing or whatever what am I best off using - WD40?

3. Does anyone know the fan spec - I could always try separating it from the housing and replacing just the fan (seems a shame as it is so nicely put together and silicone sealed) if I can get a direct replacement from Maplin or the like (if they still exist).

4. Any other bright ideas?

Also - if I'm going to do the component purchase bit does anyone know the spec of the DC power connector so I can make a long power lead to stretch from the house?
·

Comments

  • Call us and we will help you resolve your fan issue.

    Bob Trudnak
    Marketing Manager
    The BBQ Guru
    1 800 288 4878
    ·
  • ;) Thanks Bob.
    ·
  • James, You can also try my direct email bbqbob@thebbqguru.com

    FYI. I spoke to or tech dept. about this and based on the information you have provided in this post, you have a dead spot on the fan. We are sending you a new fan to install into your stainless housing. It will ship today.

    Thanks,
    Bob trudnak
    Marketing Manager
    The BBQ Guru
    ·
  • Now that's customer service! :woohoo: The exact reason I bought my digiQ II. :woohoo: :woohoo:
    ·
  • Woo Hoo - absolutely great service. !

    Bob - I have a question. My BBQGuru model - the last cook or so the fan has started making a "clacking"noise (not really a click sound, but clearly not the normal quiet operation). It is about 2 1/2 years old. It works great, just noisy and makes me concerned it might fail on an overnighter.

    Thanks
    ·
  • .
    ·
  • James MBJames MB Posts: 349
    oops, sorry now I feel like I've let you down, I was just trying to get some advice to get it resolved. I was posting on my lunch break - not good form to be on a forum at work!

    I assume you can find my details, I'm guessing you don't ship many to the UK (more's the pity).

    Listen that's excellent service, we're not used to that here in the UK!
    ·
  • If it is making a noise, there is either a melted fan blade, some type of debres in the fan or try slightly loosening or tightening the fan housing to see if the noise goes away. Let me know what you find.

    Bob
    ·
  • Not a problem James. I am happy we can help!!

    Bob
    ·
  • crghc98crghc98 Posts: 1,006
    Let me say...I don't have a guru, I want a guru, not sure if I really need a guru....

    But when I convince myself and my wife I now know exactly which company's I will be buying.

    Nice to see that kind of customer service.
    ·
  • Thanks, Bob.

    I am packing and leaving soon for the fest in Plano, TX. I will check out your suggestions the first of the week.
    ·
  • danny285danny285 Posts: 360
    Great products and great service
    ·
  • Thanks guys. We always do our best.

    Bob
    ·
Sign In or Register to comment.