Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
Welcome to the EGGhead Forum - a great place to visit and packed with tips and EGGspert advice! You can also join the conversation and get more information and amazing recipes by following Big Green Egg at:

Facebook  |  Twitter  |  Instagram  |  Pinterest  |  Youtube  |  Vimeo
Share your photos by tagging us and using the hashtag #EGGhead4Life.


In Atlanta? Come visit Big Green Egg headquarters, see our new showroom and check out the History of the EGG Museum and Culinary Center!  3786 DeKalb Technology Parkway, Atlanta, GA 30340.

DigiQ II help

DaleDale Posts: 41
edited 5:19PM in EggHead Forum
I have two butts on on my Large BGE right now and using the DidiQ for the first time. I don't see anything in the instruction about setting the top vent (daisy wheel)

My temp has way over shot, currently at 265 and I set if for 230, so I suspect the top is too open.

Any advice here?

Thanks,

Dale

Comments

  • FidelFidel Posts: 10,172
    Daisy petals just to a sliver. You may want to adjust the slide damper down to 1/2 or 1/3 open as well.
  • DaleDale Posts: 41
    Thanks, I do have the damper down to 1/2 already

    So the top is reallt set to a smaller opening than using w/o the fan?
  • Fire WalkerFire Walker Posts: 241
    The main swivel should be closed and the petals of the daisy wheel sould be cracked about half open, but more importantly the fan input vent should be about half closed thats the vent shutter thats between the fan and the egg. Wether the fan is on or off the egg will suck air through that openning.
    Fire Walker
  • DaleDale Posts: 41
    Fire Walker, thanks, that's exactly where I now have it set, still at 260, I imagine it will take some time to cool down.

    Dale
  • SlotmercenarySlotmercenary Posts: 1,071
    a good rule of thumb i used was to keep the swivel closed and then insert a round toothpick into the large side of the pedals and close till you can just pull the toothpick out and that is all the space you need. good luck, once you get used to the setup and visual it gets easier then using your oven in the kitchen.
  • FidelFidel Posts: 10,172
    It will likely take 30-45 minutes before it starts cooling. Make sure the Digi fan is only running 10-20% of the time. You can tell by the number of sequential flashes of the temp. Each flash is a 10% indication.
  • 407BGE407BGE Posts: 187
    I have mine open 1/4 when doing a low and slow. Even at 1/2 I would experience run away heat. I have even tried it at 90% closed and it kept the dome at 235 without a problem.

    Less is more sometimes.
  • 407BGE407BGE Posts: 187
    I have mine open 1/4 when doing a low and slow. Even at 1/2 I would experience run away heat. I have even tried it at 90% closed and it kept the dome at 235 without a problem.

    Less is more sometimes.
  • DaleDale Posts: 41
    and your set up is like mine, LBGE, 10 cfm fan?

    I just do everything too fast, just ask my wife!
  • AZRPAZRP Posts: 10,116
    Even if you have them shut all the way, the fan will find enough leaky spots to push out the air. Half way open on the petals is too much. Actually if you have the top choked down enough, you really don't have to have the fan damper choked down. -RP
  • BobSBobS Posts: 2,485
    I have the 10 CFM fan on a large BGE and I run it with the top closed completely and the damper on the fan at 1/4 open.

    If you have the temp clip for the Guru, on the grate, it will be cooler than your dome.

    The initial temp reported is nothing to lose sleep over.

    When the fan on the Guru is not operating, there is still a natural draft through the unit, that is why it is better to have the top closed.
Sign In or Register to comment.
Click here for Forum Use Guidelines.