Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
Welcome to the EGGhead Forum - a great place to visit and packed with tips and EGGspert advice! You can also join the conversation and get more information and amazing kamado recipes by following Big Green Egg at:

Facebook  |  Twitter  |  Instagram  |  Pinterest  |  Youtube  |  Vimeo
Share your photos by tagging us and using the hashtag #EGGhead4Life.


In Atlanta? Come visit Big Green Egg headquarters, including our retail showroom, the History of the EGG Museum and Culinary Center!  3786 DeKalb Technology Parkway, Atlanta, GA 30340.

need help with stuck/tight hinge

so i'm getting ready to make burgers for tonight's steeler/ravens game, go to open up my 10-year-old large egg, and the hinge won't let me open the dome more than 6 inches . . . i tighten screws next to the springs and on the dome itself, but that doesn't work -- it still won't open.[p]am i tightening too much? too little? do i need to take the whole hinge off (which i really don't want to do, as they're so difficult to get on; this is my second one over the years)?[p]it doesn't seem to be weather related (as terrible and rainy as it is here in pittsburgh) -- it's not frozen shut, in other words.[p]any troubleshooting tips appreciated . . .[p] [p]

Comments

  • jack lambert's teeth,[p]Is that the ex Steeler Lambert from Buzzard Breath Arkansas[p]Steve

    Steve 

    Caledon, ON

     

  • uncbbquncbbq Posts: 165
    Little Steven,
    I had a similar problem a couple of months ago. The extended screw to which the spring is attached had bent and was binding when I tried to open it. This may be your problem, too. Look at the bolts in the hinge to see if one is bent. I'd lube it up well. I didn't recognize what was going on until after a couple of weeks of this, the bolt broke with a bang and the spring just dangled until I could replace the hinge mechanism, which BGE replaced under warranty.
    Good luck

  • jack lambert's teeth,
    I had a similar problem during the past summer. It turned out to be one of the bolts on the hinge. I removed the springs, loosened, lubed and replaced the nuts and bolts, reattached the springs and all worked fine.
    Good luck,[p]Paul

  • thanks for the help on this -- will check the bolts and get out the spray


  • any tips on getting the spring back on, once it's been removed for cleaning and a new bolt replaced? -- it's a powerful little bugger[p]

Sign In or Register to comment.
Click here for Forum Use Guidelines.