Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
Welcome to the EGGhead Forum - a great place to visit and packed with tips and EGGspert advice! You can also join the conversation and get more information and amazing recipes by following Big Green Egg at:

Facebook  |  Twitter  |  Instagram  |  Pinterest  |  Youtube  |  Vimeo
Share your photos by tagging us and using the hashtag #EGGhead4Life.


In Atlanta? Come visit Big Green Egg headquarters, see our new showroom and check out the History of the EGG Museum and Culinary Center!  3786 DeKalb Technology Parkway, Atlanta, GA 30340.

Weird Maverick issue

jlsmjlsm Posts: 906
Cooking a brisket for the first time in ages and I seem to have issues with my Maverick 732: The food probe registers 153* with the meat right out of the fridge. I unplugged everything and turned everything off. Same problem. I reinserted the probe. Same problem. And I made sure the probe wasn't touching the lid. Darn. Briskets can be tricky without complications. Any ideas? 
*******
Owner of a large and a beloved mini in Philadelphia

Comments

  • robnybbqrobnybbq Posts: 1,897
    Bad probe.  They do not last.

    _______________________________________________________________
    LBGE, Adjustable Rig, Spider, High-Que grate, maverick ET-732, Thermapen,


    Garnerville, NY
  • ShiffShiff Posts: 1,513
    Put the probe in boiling water to see what it reads.  Did you ever use the maverick on a direct cook?  If so, the wires might have been overheated.  Also, be sure you have really plugged them in all the way. There have been reports where it reads  incorrectly if not pushed in all the way.

    When you run the wires, always be sure to run them along the platesetter and then over the gasket so hey don't get exposed to high heat.

    Call Maverick, they have usually been very good about replacing bad probes.
    Large BGE
    Barry, Lancaster, PA
  • jlsmjlsm Posts: 906
    I've babied the probes; no direct cook and always over a leg. I did take it out of the meat and put it in ice water to bring the reading down. Now it seems OK; it's registering the same as the Thermapen. Odd. 
    *******
    Owner of a large and a beloved mini in Philadelphia
  • dougbackerdougbacker Posts: 277
    jlsm sounds like you need to dig out that spare set of probes :-t

    --------------------------------------------------------
    South Dakota
    KBØQBT
    Large BGE, 
    Mini BGE
    36" Blackstone Griddle
    Phoenix Gasser
    Cyber Q WIFI

    And a deck box full of toy's


Sign In or Register to comment.
Click here for Forum Use Guidelines.