Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
Welcome to the EGGhead Forum - a great place to visit and packed with tips and EGGspert advice! You can also join the conversation and get more information and amazing recipes by following Big Green Egg at:

Facebook  |  Twitter  |  Instagram  |  Pinterest  |  Youtube  |  Vimeo
Share your photos by tagging us and using the hashtag #EGGhead4Life.


In Atlanta? Come visit Big Green Egg headquarters, see our new showroom and check out the History of the EGG Museum and Culinary Center!  3786 DeKalb Technology Parkway, Atlanta, GA 30340.

Tempature

I'm a three year old BGE owner. I've cook about everything and have used it hundreds of times. My question: I can't seem to get a high temp lately. I've always used Royal Oak red bag from Resturant Depot. I like it fine and love the price. It seems there's not as many big and medium pieces as before though. My EGG is clean. Air holes are clear. What am I doing wrong? Fuel damp? It's not sparking or smoking. What say you? JJS

Comments

  • cazzycazzy Posts: 8,808
    What max temp are you getting to?

    How much lump are you putting in?

    How many spots are you lighting?

    The high-que will help quite a bit:
    http://www.amazon.com/gp/aw/d/B004XU1FES
    Just a hack that makes some $hitty BBQ....
  • MrCookingNurseMrCookingNurse Posts: 4,393
    Fuels damp.

    "It's not sparking or smoking"

    Uh :-?? Something's wrong there.


    High que is great option, but you should be able to get well around the temp gauge and back in less than 20 min with royal oak and stock set up in a clean egg.


    _______________________________________________

    XLBGE 
  • Fred19FlintstoneFred19Flintstone Posts: 6,520

    Perhaps the lump quality is down?  If your egg is clean, the vents set at normal settings and you're not getting the previous performance, then the only variable would be the lump quality.  Either it's a storage issue or the lump itself is lower quality.  Your investigation continues... 

    ........................................................................................

    Flint, Michigan.  If the lead bullets don't kill you, the leaded water will.

  • I actually use Grill Grates. I'm only getting about 300. I fill it almost full. Always have. I light four spots. 1,3,6 and 9 o'clock.
  • Fred19FlintstoneFred19Flintstone Posts: 6,520
    I would re-check your airflow to make sure it's unobstructed and if unobstructed, I would buy another bag of lump fresh from another store.

    ........................................................................................

    Flint, Michigan.  If the lead bullets don't kill you, the leaded water will.

  • ChubbsChubbs Posts: 6,692
    Remove guts to see if ash buildup back there. If not, try a different lump. Only two things possible when temp doesn't rise.
    Columbia, SC --- LBGE 2011 -- MINI BGE 2013
  • Little StevenLittle Steven Posts: 339
    I'm a three year old BGE owner. I've cook about everything and have used it hundreds of times. My question: I can't seem to get a high temp lately. I've always used Royal Oak red bag from Resturant Depot. I like it fine and love the price. It seems there's not as many big and medium pieces as before though. My EGG is clean. Air holes are clear. What am I doing wrong? Fuel damp? It's not sparking or smoking. What say you? JJS

  • Little StevenLittle Steven Posts: 339
    I hope your mommy and daddy are watching you. Seriously, is the opening in the firebox lined up with the lower vent?
Sign In or Register to comment.
Click here for Forum Use Guidelines.