Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
It’s almost Halloween and if you’re cooking on your EGG, you may end up with more people knocking on your door asking for pork chops than candy! In case you’re willing to share and want to please a crowd, we recommend warm Margherita Pizza, FGL’s Lemon Pepper Wings or our favorite, S’mores in a Cone!


If you missed the 17th Annual EGGtoberfest here are the highlights Click Here Fall is upon us, and it's a great time for getting out to one of the many #EGGfests around the country - see a list here

Unhappy with iGrill: is it my fault?

So I have had my iGrill a few months. Basic but overall I liked it. Doing pork butt today and doing turbo method. So egg is about 350. I have the iGrill hanging from S hook like always. Noticed was no longer connected to Bluetooth. I opened the back up bc it would power on. I put fresh batteries in this morn so thought was weird. Liquid everywhere, I assume battery acid. The batteries were burnt looking. The iGrill itself on outside wasn't really hot, plastic not melted and still very white. Am I wrong for assuming that was a good spot to hang? The probe cable isn't terrible long, and didn't want sitting on the shelf from nest bc then in direct sunlight. Now it isn't working and I will have to open egg lid to keep checking temp with thermo.
Boom

Comments

  • khristyjeffkhristyjeff Posts: 154
    I don't own one but wondered if your thinking is that the new batteries you installed were defective since the outside enclosure wasn't melted or anything.  I looked at their website but nothing similar to what you experienced.  Maybe clean out the inside, replace again with different batteries, then follow their instructions for resetting the unit. Good luck.  Hope your butt turns out great anyway! 
Sign In or Register to comment.