Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
Welcome to the EGGhead Forum - a great place to visit and packed with tips and EGGspert advice! You can also join the conversation and get more information and amazing kamado recipes by following Big Green Egg at:

Facebook  |  Twitter  |  Instagram  |  Pinterest  |  Youtube  |  Vimeo
Share your photos by tagging us and using the hashtag #EGGhead4Life.


In Atlanta? Come visit Big Green Egg headquarters, including our retail showroom, the History of the EGG Museum and Culinary Center!  3786 DeKalb Technology Parkway, Atlanta, GA 30340.

temp gauge!!!

couldnt get my temp over 200 tonite!so i thought that the fire box was blocked with lump/ash (even though i cleaned it last cook!) so as i was shutting er down,the temp started dropping,to 700!!!! the temp gauge went all the way around!!!i didnt think they could do that or that u could get the egg that hot!!!!! i was shoveling while it was warming up! should have realized it was too hot the fire looked great when i opened the lid!!!! oh well live and learn!! just wondering if this has happened to any one else? and does anyone know if this has buggered my temp gauge???? thanks!!!..............oh by the way after all was done the ribs turned out great

Comments

  • I've spun mine all the way around 3 times
  • I almost did the same thing once. You will probably be okay. 



    Louisville, GA - 2 Large BGE's
  • TjcoleyTjcoley Posts: 3,500
    I've spun the gauge a few times. After doing so, you should calibrate it. Boil some water, put in the probe, making sure it's not touching the pot and make sure it reads 100C or 212F. Adjust for sea level if you are way above. If the probe is off, use a pair of pliers to hold the nut on the back and rotate the dial til it reads right.
    __________________________________________
    It's not a science, it's an art. And it's flawed.
    - Camp Hill, PA
  • Tjcoley said:
    I've spun the gauge a few times. After doing so, you should calibrate it. Boil some water, put in the probe, making sure it's not touching the pot and make sure it reads 100C or 212F. Adjust for sea level if you are way above. If the probe is off, use a pair of pliers to hold the nut on the back and rotate the dial til it reads right.

    thanks


     

  • Everyone has done this, only some of us will admit it, welcome to the once around gang!
    Delta B.C. - Vee-Gan: old Indian word for poor hunter. 
  • I've put this one around to the 300 mark.

    image

    Steve 

    Caledon, ON

     

  • thamks for the feedback every1 now i dont feel like a tool!!!!!
  • Exact thing happened to me on my first cook. It's really absurd there is no peg in the thermometer. If you'd like, check out some of the comments toward the middle of this link where I started having temp issues : http://eggheadforum.com/discussion/1148179/converting-from-weber-smokey-mountain-to-bge-questions#latest
Sign In or Register to comment.
Click here for Forum Use Guidelines.