Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
It’s that time of year again-time to hop on out to your backyard for an EGG hunt. If you’re lucky, you’ll only have to search as far as your patio! Planning on cooking Easter Sunday? Check out our Easter Menu. If you’re looking for a sweet treat to enjoy with the whole family, try at least one of our sweet treats, if not both: Grilled Peeps & Carrot Cupcakes. Lastly, if you’re having company, our Pinterest page has lots of ideas for entertaining. We hope you have an EGGstra tasty holiday!



The Big Green Egg headquarters has moved - come visit our new location and check out the museum! 3786 DeKalb Technology Parkway, Atlanta, GA 30340

Maverick 732-- Junk

pineypiney Posts: 496
edited May 2012 in EggHead Forum
After reading several reviews I bought a Maverick 732. This unit is junk I have tried to use it twice with no luck.I have replaced batteries, turned unit off and on again, tried to re-sync and still does not work properly. I will contact the mfg. tomorrow. I personally think it is just more junk from China.
Lenoir, N.C.
·

Comments

  • bclarksiclebclarksicle Posts: 101
    sounds like a defective unit.  It happens.
    ·
  • travisstricktravisstrick Posts: 4,748
    I just ordered one. I'll report after I use it. Hopefully it works better.
    Be careful, man! I've got a beverage here.
    ·
  • ShiffShiff Posts: 1,231
    All I can say is that mine works great.   Syncs every time and the range is far better than the ET-73 I used to have.  I'm sure the manufacturer will swap you for a new one.
    Barry Lancaster, PA
    ·
  • pineypiney Posts: 496
    Shiff I feel the mfg will cover this it does have a 90 day warranty. It is sitting on my desk now reading food 106, bbq LLL. Last night it read all kinds of weird stuff. 
    Lenoir, N.C.
    ·
  • Mine works like a champ



    ·
  • gerhardkgerhardk Posts: 813
    edited May 2012
    sounds like a bad probe, switch were the meat probe and
     bbq probe plug into the sending unit, if the error message is now reversed I would think you have a defective probe.

    Gerhard
    ·
  • pineypiney Posts: 496
    gerhardk, I should have posted eariler that I was messing with this thing and did switch the probes and that seems to be the problem. Thanks for the input and I am sure we have found the problem, I will notify mfg Monday and see what they say but, I feel sure they will correct the issue.  
    Lenoir, N.C.
    ·
  • MikeGMikeG Posts: 174
    Lucky yours was junk from the start.  Mine didn't stop working until the Amazon return period was expired.  I'll not risk another.
    ·
  • pineypiney Posts: 496
    MikeG, I bought mine from someone on Ebay but I am going to mfg for help, I hope that works.
    Lenoir, N.C.
    ·
Sign In or Register to comment.