Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
It doesn’t get much hotter than the EGG cookin’ in July! Make sure to keep yourself hydrated with a bit of whatever you’re using for the Beer Can Chicken. Ice Cream Sandwiches are also a great way to stay cool. Looking for some great ideas for a summer cook out? Try out a Pimento Cheeseburger or Dr. BBQ’s Spare Rib Surprise. Just don’t be surprised if your neighbors stop by for a quick bite when they smell what you’re cooking!

Big Green Egg headquarters has moved - come visit our new showroom and check out the museum and culinary center too! 3786 DeKalb Technology Parkway, Atlanta, GA 30340

Maverick 732-- Junk

pineypiney Posts: 601
edited May 2012 in EggHead Forum
After reading several reviews I bought a Maverick 732. This unit is junk I have tried to use it twice with no luck.I have replaced batteries, turned unit off and on again, tried to re-sync and still does not work properly. I will contact the mfg. tomorrow. I personally think it is just more junk from China.
Lenoir, N.C.
·

Comments

  • bclarksiclebclarksicle Posts: 108
    sounds like a defective unit.  It happens.
    ·
  • travisstricktravisstrick Posts: 4,822
    I just ordered one. I'll report after I use it. Hopefully it works better.
    Be careful, man! I've got a beverage here.
    ·
  • ShiffShiff Posts: 1,319
    All I can say is that mine works great.   Syncs every time and the range is far better than the ET-73 I used to have.  I'm sure the manufacturer will swap you for a new one.
    Barry Lancaster, PA
    ·
  • pineypiney Posts: 601
    Shiff I feel the mfg will cover this it does have a 90 day warranty. It is sitting on my desk now reading food 106, bbq LLL. Last night it read all kinds of weird stuff. 
    Lenoir, N.C.
    ·
  • Mine works like a champ



    ·
  • gerhardkgerhardk Posts: 818
    edited May 2012
    sounds like a bad probe, switch were the meat probe and
     bbq probe plug into the sending unit, if the error message is now reversed I would think you have a defective probe.

    Gerhard
    ·
  • pineypiney Posts: 601
    gerhardk, I should have posted eariler that I was messing with this thing and did switch the probes and that seems to be the problem. Thanks for the input and I am sure we have found the problem, I will notify mfg Monday and see what they say but, I feel sure they will correct the issue.  
    Lenoir, N.C.
    ·
  • MikeGMikeG Posts: 174
    Lucky yours was junk from the start.  Mine didn't stop working until the Amazon return period was expired.  I'll not risk another.
    ·
  • pineypiney Posts: 601
    MikeG, I bought mine from someone on Ebay but I am going to mfg for help, I hope that works.
    Lenoir, N.C.
    ·
Sign In or Register to comment.