Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
It feels as though we’ve waited forever for college football to start, and finally the wait is over! Check out our tailgating page for recipes that are sure to become fan favorites. As an added bonus, the day before Labor Day is National Bacon Day and we don’t know about you, but we like putting bacon on anything and everything, so we’ll definitely be celebrating that. It's time to think about getting out to one of the many #EGGfests around the country - see a list here

Maverick junk

BaysidebobBaysidebob Posts: 488
edited December 2011 in EggHead Forum
Push this wait for that and on and on.  This thing worked great for a coupl days and quit.  Replaced batteries, no help.  I follow the directions and nothing works.  I HATE this thing.  Is there a remote probe out there that actually works?  I just got it going again but it loses the signal even though they are less than a foot apart.
My actuary says I'm dead.

Comments

  • Which model do you have? I had the same experience with the ET73. I changed to the ET732 and it works well. Customer service at Maverick was wonderful. Try sending them a message.
  • I agree with howmeisterg - my ET-732 from last Xmas is awesome. Batteries are still good. No problems what-so-ever. Be careful, the ET-73 - the older one - has some issues with the probes. Still - some got replacements under warrantee - or bought new probes for a reasonable price.

    I do have to admit that I use it only for the very long cooks. Otherwise - no need for any fancy thermometer - the dial thing that came with the BGE works for me - and does not require batteries!

Sign In or Register to comment.