Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
Welcome to the EGGhead Forum - a great place to visit and packed with tips and EGGspert advice! You can also join the conversation and get more information and amazing recipes by following Big Green Egg at:

Facebook  |  Twitter  |  Instagram  |  Pinterest  |  Youtube  |  Vimeo
Share your photos by tagging us and using the hashtag #EGGhead4Life.


In Atlanta? Come visit Big Green Egg headquarters, see our new showroom and check out the History of the EGG Museum and Culinary Center!  3786 DeKalb Technology Parkway, Atlanta, GA 30340.

Not too happy with BBQ Guru

marrtmarrt Posts: 22
edited September 2011 in EggHead Forum
I've been using my BBQ Guru DigiQ for a couple years now.  I'm on my third circuit board (rain) and third meat probe.  The pit probe has always worked fine.  However, I've had problems with the meat probe from day one.  Often, it will not read anything.  This has been true across multiple circuit boards and probes.  I always insert all probes before connecting the power.   Any ideas? 

Comments

  • I'd call them and see what they have to say.  They are probably better equiped to work on your mystery  meat probe than anyone here.
    The Naked Whiz
  • Mass. Wine GuyMass. Wine Guy Posts: 19
    edited September 2011
    I'm very close to buying the IQue 110. It's simpler than most, seems to have high quality components and gets good reviews.
  • I have a bad probe (pit) but it works fine otherwise.
    I grill therefore I am.....not hungy.
  • NC-CDNNC-CDN Posts: 703
    I'd call them and see what they have to say.  They are probably better equiped to work on your mystery  meat probe than anyone here.
    This.  If it's a bad unit they should be able to help.  It's the place to start before saying a BBQ Guru isn't pleasing you.  Perhaps it will once it's happy.  Good luck.  I love mine.  I personally don't use it in the rain.  I'm sure it would be okay, but that bothers me.  I just go old school in the rain. 
  • Their customer service is excellent.  My Pro Comm IV went south after a few years storage in the garage and the fixed it right up for about $50.  Call 'em up and see how they they can help you.
Sign In or Register to comment.
Click here for Forum Use Guidelines.