Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
Welcome to the EGGhead Forum - a great place to visit and packed with tips and EGGspert advice! You can also join the conversation and get more information and amazing kamado recipes by following Big Green Egg at:

Facebook  |  Twitter  |  Instagram  |  Pinterest  |  Youtube  |  Vimeo
Share your photos by tagging us and using the hashtag #EGGhead4Life.


In Atlanta? Come visit Big Green Egg headquarters, including our retail showroom, the History of the EGG Museum and Culinary Center!  3786 DeKalb Technology Parkway, Atlanta, GA 30340.

Disabled Egg

yankeefanyankeefan Posts: 35
edited 12:21PM in EggHead Forum
For the 1st time in 6 yrs my egg is non-usable so I am hoping you can lead me in the right direction to solving this.

I never had to play with the 8 bolts that make up the hinge but had to last night with no sucess. For some reason a 3/8" or so gap is now between the lid and base. To the point where I had to remove the springs to get it to close so the fire would go out.

I loosened all 8 bolts, placed about 45 lbs on the lid, tightened everything back up, put the springs back on, opened the lid.....but, back to having the large gap.

So, is there a video on how to fix this or some PDF file I can read?

Thanks,
Howard

Comments

  • HicHic Posts: 350
    I just got my egg a couple of weeks ago and watched the DVD. It did cover assembling the egg. It may be worth a watching.

    Large, medium, small and a mini. Egg'n, golfing, beer drinking, camping and following football and baseball.
    Atlanta NOTP suburbia.

  • I had the same thing happen & called BGE for direction. They said to remove the springs & reinstall the original retaining clips to realign the hinge assembly. Then put the springs back on & it should be corrected. You will need to open the lid to take off or put the springs back on.
    Hope this helps.
Sign In or Register to comment.
Click here for Forum Use Guidelines.