Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
Welcome to the EGGhead Forum - a great place to visit and packed with tips and EGGspert advice! You can also join the conversation and get more information and amazing kamado recipes by following Big Green Egg at:

Facebook  |  Twitter  |  Instagram  |  Pinterest  |  Youtube  |  Vimeo
Share your photos by tagging us and using the hashtag #EGGhead4Life.


In Atlanta? Come visit Big Green Egg headquarters, including our retail showroom, the History of the EGG Museum and Culinary Center!  3786 DeKalb Technology Parkway, Atlanta, GA 30340.

BBQ Guru- is this normal?

cobrastrikecobrastrike Posts: 28
edited 3:40PM in EggHead Forum
used my DigiQDX for the first time today on some ribs for work. I clipped the pit probe from the Guru to the temp probe of the egg. I was also using an ET-73 just for monitoring the new toy. I set the Guru for 250. After a few minutes, I noticed that the guru was showing 250, but the egg and ET-73 were reading about 315! I know that these things can be calibrated but don't they do that before it ships? I know that grid temp and dome temp are different, so just out of curiosity, I put the guru probe on the cooking grid. The temp showed around 225 or so, and the guru's fan kicked on. Once the guru was at 250, the egg temp was approaching 360 or so. What am I doing wrong? I made sure that the probe from the guru wasn't touching any food- I'm stumped.

Comments

  • FlaPoolmanFlaPoolman Posts: 11,675
    Test them all in boiling water and that will tell you where the problem is
Sign In or Register to comment.
Click here for Forum Use Guidelines.