Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
Welcome to the EGGhead Forum - a great place to visit and packed with tips and EGGspert advice! You can also join the conversation and get more information and amazing kamado recipes by following Big Green Egg at:

Facebook  |  Twitter  |  Instagram  |  Pinterest  |  Youtube  |  Vimeo
Share your photos by tagging us and using the hashtag #EGGhead4Life.


In Atlanta? Come visit Big Green Egg headquarters, including our retail showroom, the History of the EGG Museum and Culinary Center!  3786 DeKalb Technology Parkway, Atlanta, GA 30340.

My Butt story and question - Defective Guru?

HungryNephewHungryNephew Posts: 267
edited 8:26AM in EggHead Forum
This is my 5th overnight butt and the first time I have had any issues. I think my guru is defective. I set the temp for 250. I had plenty of time so I decided to give it a good hour to stabilize.

I tested both probes in boiling water and they both read 209. Everything was going just fine until I noticed that the guru (attached to thermometer) was reading 275. The real problem is that it was still blowing. I lowered the dome target temp to 235. Still blowing!

I had a feeling that I would wake up to a 400 egg so I pulled the blower out of the door and decided to go old school. I plan on giving the guru folks a call on Monday. I tested both probes in boiling water and they both read 209. Good enough.

I went to bed at 2 am with a dome temp of 252. I woke up at 5:30 with a dome temp of 190.

So...... is my butt ok? I cranked the egg up and it is now at 280.

Comments

  • "Sparky""Sparky" Posts: 6,024
    Hey Lee,I don't know about the Guru,but the butt is just fine ;) C'ya later man :)
  • Celtic WolfCeltic Wolf Posts: 9,773
    Next time that happens turn the guru off, back sure all the plugs are seated correctly and turn it back on.

    As for the butt, you are fine.
Sign In or Register to comment.
Click here for Forum Use Guidelines.