Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
Welcome to the EGGhead Forum - a great place to visit and packed with tips and EGGspert advice! You can also join the conversation and get more information and amazing kamado recipes by following Big Green Egg at:

Facebook  |  Twitter  |  Instagram  |  Pinterest  |  Youtube  |  Vimeo
Share your photos by tagging us and using the hashtag #EGGhead4Life.


In Atlanta? Come visit Big Green Egg headquarters, including our retail showroom, the History of the EGG Museum and Culinary Center!  3786 DeKalb Technology Parkway, Atlanta, GA 30340.

Small S.A. hinge yea!...and boo!

Mr. HydeMr. Hyde Posts: 99
edited 5:17AM in EggHead Forum
I finally got around to installing the new spring assist hinge on our baby egg. The good news was that it was easy to do (except when one of the little studs that hold the handle on broke when I torqued it too much, fortunately there was a spare in the hardware pack). I love the wide opening that it has now, and I won't miss having to lock down the braces each time. However, there is a gap in the back, between the top nad bottom, so I guess I will have to go with a Rutland gasket, or double thinckness of felt. Bummer!

Comments

  • WooDoggiesWooDoggies Posts: 2,390
    Mr. Hyde,[p]Before you go with a new gasket, try this..... look over your top and bottom band and make sure they run parallel with the top and bottom edge/lip of the egg. If they don't run parallel, that could be causing the gap.
    Also, try loosening the top band and then tapping all around the lid with a rubber mallet so the lid seats squarely on the base. Then retighten with a turn of the wrench and alternating with the tapping until the lid is secure....... hopefully that will solve the gap problem.
    Good luck!
    John

  • The Naked WhizThe Naked Whiz Posts: 7,780
    Mr. Hyde,
    I was under the impression that this is the problem that the new hinge was supposed to address, so I'd contact your dealer or BGE and let them know.[p]TNW

    The Naked Whiz
  • Mr. Hyde,
    Well, I have been waiting for this hinge but now I am not so sure. Is anyone else out there having problems with the new hinge? Before I sink $66.00 (hinge + shipping) into this I would like to be sure that I am not just exchanging one problem for another.
    Thanks, SG

  • BoccieBoccie Posts: 186
    Mr. Hyde,[p]I installed mine two days ago. There was a small gap in the back after I put it on, so I loosened the top band and my wife pressed down on the dome to make sure it was all sitting flush, then I retightened.[p]There is no gap now. Everything sits flush. Maybe this will work for you also. Sometimes some adjustments are necessary after a new install.
  • Mr. Hyde,
    When I installed new spring assist band on my small this past Friday I also had a gap. My dealer in Augusta Georgia informed me they had another band in stock with which they will replace it with. My wife will exchange the band for me while I am working tomorrow. The store is closed by the time I get off work. My problem when I got off work today to remove the old band I notice at the bottom where the pin in the center at the bottom half has chipped the ceramic at an angle from the pin hole to the top approximately one half inch deep to the top. The angle is as such that it does not go all the way to the inside to notice on the inside. The pin in the bottom front would not do its job though.I was careful and made sure to align the pin properly. I’m not sure at this point what caused the chipped to take place or as to as to the solution. I will call BGE in Atlanta and hope they will help.

  • Mr. HydeMr. Hyde Posts: 99
    [p]Thanks Guys! I got home and tweeked it a little (with a rubber hammer!). After enough persuasion, I got it much better. There is still the slightest gap, but I think that if I replace the gasket (it is pretty much toast) it will be better than new.

Sign In or Register to comment.
Click here for Forum Use Guidelines.