Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
With winter in full gear, we’re enjoying all the awesome photos of EGGs in the cold weather. Stay warm with some of our favorite Dutch oven recipes: Chicken & Dumplings, Chili Con Carne and BLT Soup.

The Big Green Egg headquarters has moved - come visit our new location and check out the museum! 3786 DeKalb Technology Parkway, Atlanta, GA 30340

Help with DigiQ

run4jcrun4jc Posts: 107
edited November -1 in EggHead Forum
Help! ! Panic attack! I'm trying to do a test cook with chicken breasts and the DigiQ - right out of the gate, the probes won't work - I'm getting a - - - on the display for food and pit temps. I've unplugged the power, unplugged and replugged and checked the probe plugs. Nothing works. The fan is working and I can run through the menu system - it just won't display a temp. At first it was showing a ridiculously low pit temp dropping one degree at a time, then the display went to the - - -. I've emailed Fred but I'm thinking with the holiday I may not get a quick response and perhaps one of you have been through this. can anyone help? My Butt is in danger!!
·

Comments

  • BacchusBacchus Posts: 6,019
    Stick it back in the box and fly by the seat of your pants. It will make for some very good chicken.
    ·
  • Push the probes in FIRMLY...

    Spacey
    ·
  • run4jcrun4jc Posts: 107
    I flew by the seat of my pants and the chicken was good - but again, the chicken was just a test bed, so to speak. And I did push the probes in firmly -

    Oddly, if I took the pit probe and the food probe out they registered the ambient temps - but the minute they were put into the food and the pit they went back to the --- display. I sure hope Fred gets back to me soon!
    ·
  • KnaufKnauf Posts: 337
    The first time I tried mine I turned on the transmitter (probe side) and put the battery door back on then I turned on the receiver and got the same thing. The directions say to turn them on within a minute of each other. Now I just turn on the trans and then rec and then ;ut the battery cover on and I haven't had any trouble.
    ·
  • run4jcrun4jc Posts: 107
    We must have different devices - I have no battery cover. I have the BBQ Guru DigiQ II - is that what you have?
    ·
Sign In or Register to comment.