Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
We may still be full from Thanksgiving, but that doesn’t mean we’re not already looking forward to a delicious Christmas dinner, too! Keep our Holiday Entertaining Publication handy throughout December for all your holiday dinner needs. But you can also find some of our favorites on our Country Christmas page, including Christmas Ham and Peach Cobbler. Happy cooking!

Big Green Egg headquarters has moved - come visit our new showroom and check out the museum and culinary center too! 3786 DeKalb Technology Parkway, Atlanta, GA 30340.


Rick GRick G Posts: 166
edited 1:35AM in EggHead Forum
Hey wmk;[p]I just had you send me a new password for the new forum and it works...sort of. When I type in my username and password it says "Your registration process is not yet complete. Please watch your E-mail for further instructions" or something close to that. So what do I need to do??


  • Rick GRick G Posts: 166
    WMK;[p]P.S. There is nothing in my spam folder regarding the new forum.

  • Rick GRick G Posts: 166
  • Which block of the forum are you trying to login with? I received this same message when I tried to login using the block on the left side, half way down the page. This message disappeared for me when I used the login block on the top right of the page.

    Seems like every time I try to help something changes and it is always fixed before I post. Might be the same with this. Good Luck
  • Rick GRick G Posts: 166
    I guess it worked.....Im posting on the new forum as we speak, so I guess I'm good to go. Thanks for the assist!!!
  • Rick GRick G Posts: 166
    one more do I use those little buttons to post a pic???
  • BraddogBraddog Posts: 212

    Thanks for that tidbit. I've been unsuccessful trying to raise WMK on either forum, but this seems to work for me as well. Seems completely counter-intuitive that you can't use the login fields that are in your face on the left though.

    Happy new year!

  • RickG,
    I'm not sure what block you are clicking on to login. I get the same message when I try using the one on the left side half way down. Try using the one at the top of the page on the right.

Sign In or Register to comment.