Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
Welcome to the EGGhead Forum - a great place to visit and packed with tips and EGGspert advice! You can also join the conversation and get more information and amazing recipes by following Big Green Egg at:

Facebook  |  Twitter  |  Instagram  |  Pinterest  |  Youtube  |  Vimeo
Share your photos by tagging us and using the hashtag #EGGhead4Life.


In Atlanta? Come visit Big Green Egg headquarters, see our new showroom and check out the History of the EGG Museum and Culinary Center!  3786 DeKalb Technology Parkway, Atlanta, GA 30340.

First time

ShelbyShelby Posts: 803
edited 9:56AM in EggHead Forum
Hello everyone!
I registered a couple of weeks ago, but do to some internal/server problems, haven't been able to post, till now. My thanks to our webmaster for working to solve this problem.
Now, I purchased my large BGE last Saturday. Table I was working on wasn't finished till Thursday. Set it up and was cooking in less than 20 minutes. Just sliced a few pieces of pork off a whole pork loin. Very pleased with results.
Tonight, little more experimenting...did some chicken breasts and baked potatoes. Yes, I know a basic meal but still in the learning stages of my Egg. Came out well; a tad too long cooking the chicken. Didn't judge potatoes well and that forced the chicken to cook a little long. But I'm learning it and enjoying the "test" meals in the meantime!
Out of town next week on business; hopefully get to try either shrimp or catfish on it soon.

Comments

  • Char-WoodyChar-Woody Posts: 2,642
    Shelby, A belated welcome and your learning curve on the BGE is doing nicely. You will soon be a pro with it. It's such a easy, flexible cooking machine that almost leads you by the hand. Holler when we can help..
    Char-Woody

  • Tim MTim M Posts: 2,410
    Shelby,[p]Glad to see you beat that posting problem. I would be curious to know what was the actual problem. As I said in the emails, I always thought it was a problem on your end, what was it?[p]Glad you finally made it in, Welcome.[p]Tim
  • SpinSpin Posts: 1,375
    Shelby,[p]Welcome to the Egg family and forum. Give a shout if we can help you along your way.[p]Spin

  • MickeyTMickeyT Posts: 607
    Shelby,[p]Welcome!!!![p]6 months ago I wasn't sure how to start the dang thing, now I'm cookin brisket,jerky,whole chickens,salmon,cornish hens,butt,ribs and all kinds of fun stuff.[p]The guys and gals on this site are truly good folks and good cooks to boot.[p]If you do like I did, and jump in with both feet, we'll be seein your posts here all the time. :>)[p]Mick

  • ShelbyShelby Posts: 803
    Tim M,
    I'd love to tell you but according to our webmaster, there was some sort of internal glitch on the server software and he was able to corrrect it for me. I kinda figured it was something like that. A friend's website has the exact same posting format on that forum and I have no problems there.
    Anyway, glad to be here and looking forward to sharing and learning.

Sign In or Register to comment.
Click here for Forum Use Guidelines.