Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
Welcome to the EGGhead Forum - a great place to visit and packed with tips and EGGspert advice! You can also join the conversation and get more information and amazing kamado recipes by following Big Green Egg at:

Facebook  |  Twitter  |  Instagram  |  Pinterest  |  Youtube  |  Vimeo
Share your photos by tagging us and using the hashtag #EGGhead4Life.

In Atlanta? Come visit Big Green Egg headquarters, including our retail showroom, the History of the EGG Museum and Culinary Center!  3786 DeKalb Technology Parkway, Atlanta, GA 30340.

"Chemical" Odor on Roasted Meats

FairalbionFairalbion Posts: 139
edited 12:28PM in EggHead Forum
I have had my Large BGE for 3 years now and have often noticed both a smell and flavor in meats and poultry that have been roasted. Examples include beef roasts, turkeys, whole chickens... anything, really, that requires roasting in the 350° and above range. Words that come to mind to describe the flavor and odor are: "chemical," "combustion products," "my dad's old coke-fired boiler from when I was a kid."[p]I notice this neither in quickly-cooked foods, like steaks or chicken breast, nor in slow-smoked foods like ribs, Boston Butts etc.[p]I'd be grateful for your suggestions.


  • Fairalbion,
    2 questions[p]what do you start your fire with? ..[p]do you let your lump get well established before putting the food on? .[p]

  • RhumAndJerkRhumAndJerk Posts: 1,506
    mad max beyond eggdome,
    Also, what brand of Charcoal are you using?
    On occasion, you do get a bad bag of lump, regardless of brand.

  • BlueSmokeBlueSmoke Posts: 1,678
    mad max beyond eggdome,
    I've dramatically reduced off aromas since I began to let all the new lump catch before putting food on the grill.[p]Ken

  • BordersBorders Posts: 665
    Fairalbion, You may be experiencing the off odors caused by juices hitting the hot coals and making "bad smoke". I had this problem with chicken early on and remedied it 2 ways. One is to cook indirect with some sort of drip pan catching all the juice. The other is to cook direct on a raised grid, with the chicken on the outside of the grid, so that drippings only hit the coals.

  • BlueSmoke,[p]Ditto.[p]Aloha![p]Greg
  • Sorry, I should have included this...[p]- I light the lump with MAPP gas
    - I use BGE brand lump
    - I cook my roasts indirect - over a drip pan on a plate setter
    - I usually leave about 20 minutes between lighting and putting the meat on.

  • stikestike Posts: 15,597
    the twenty minute wait time might be part of the problem. perhaps the MAPP gets you up to temp more quickly than us paraffin-cube guys, and we somehow burn off more of the 'chemical' taste you are talking of (on the 'neighboring' lump).[p]but still, i don't know if that's the problem... when I load up my lump for a 350 cook, i certainly don't wait for it ALL to be ignited (as was suggested) before putting the meat on. there's no way you could wait for ALL the lump to ignite, or you'd be waiting for 4 hours if you filled the firebox. that, or you'd be at 1200 degrees. some lump is always unlit during a cook, and some is igniting.[p]lemme ask a stoopid question... have you ever had indirect-roasted stuff from ANOTHER egger's egg? does that taste fine to you? if not, it could be that maybe the taste is something we (the rest of us) taste but don't find objectionable. ...and simply because there's so much more smoke in a lo-and-slo, it covers the usually "chemical" taste you perceive. ...the high temp sears likely burn it off, and they are very short cooks anyway, so you don't get any chem-taste there.[p]could it be you don't like the small amount of smoke you get from the lump itself?

    ed egli avea del cul fatto trombetta -Dante
  • stike,
    Some good thoughts there, tks.
    Racking my memory: I remember getting this same taste on a few occassions in the days when I did (or, at least, attempted) roasts on a Weber kettle using briquettes for fuel. I got this particularly one time when I overcooked a turkey. I have never noticed it when using the gas range's oven in the kitchen.[p]It has to be from the lump's VOCs.... or maybe it's just my hypersensitive nose & tastebuds. :-)

  • dhuffjrdhuffjr Posts: 3,182
    Borders wrote:
    Fairalbion, You may be experiencing the off odors caused by juices hitting the hot coals and making "bad smoke"

    This is the main problem I've noticed. This and not letting the fire burn "clean".
  • fishlessmanfishlessman Posts: 19,710
    you may want to try some different lumps to experiment with. i like beef cooked over ozark oak and the poultry over wicked good. they impart different flavors.

  • tach18ktach18k Posts: 1,607
    Fairalbion, I got the same setup, It takes about 20 minutes to get the BGE lump to 300, lately its been taking longer and not as hot. I know what you mean about an odd smell, to me I thought is was some juices that got on the lump, even though I also run a platesetter and drip pan. I thought it was the gasket/glue, which on the gasket I just burnt and tore off a small 3 inch portion at 600 degrees, very odd!!! My temp gage is fine and exact. Why I say this is you may have some hot spots near the sides, and the gasket /glue is starting to get nasty, thus the smell. does this happen with a cleaned out egg, burned off platesetter, sides and grate? and new lump

  • stikestike Posts: 15,597
    well, the smoke you like from the low and slos is caused by VOCs in the wood you smoke with....[p]but i think the sticking point is you get more of it on a turkey, say, than you want.[p]the vast majrity of my cooks include maybe 50% old lump (left-over from the last cook). are all of your roast-cooks NEW lump? i get much less of the tinge you are referring to when I have a sig. portion of older lump in there.

    ed egli avea del cul fatto trombetta -Dante
Sign In or Register to comment.
Click here for Forum Use Guidelines.