Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
Welcome to the EGGhead Forum - a great place to visit and packed with tips and EGGspert advice! You can also join the conversation and get more information and amazing recipes by following Big Green Egg at:

Facebook  |  Twitter  |  Instagram  |  Pinterest  |  Youtube  |  Vimeo
Share your photos by tagging us and using the hashtag #EGGhead4Life.


In Atlanta? Come visit Big Green Egg headquarters, see our new showroom and check out the History of the EGG Museum and Culinary Center!  3786 DeKalb Technology Parkway, Atlanta, GA 30340.

Auto-loc Hinge

edited 3:14AM in EggHead Forum
I recently purchased a auto-loc hinge. Inside the box is a white tube of something. I see no mention on the instructin manual as to what it is or what to do with it. Can someone tell me what to do with it?

Comments

  • Char-WoodyChar-Woody Posts: 2,642
    Cajun Boy, I sent you a e.mail..your e.mail was returned. Here is what I sent you
    I will guess with ya..but I think its adhesive to use to further secure the bands to the dome.
    Let me give you a small tip...!

    (1) Check the band for a dimple on the front top and the back top area.

    (2) Make sure those dimples will fit nicely in the recesses in the ceramic dome that they are meant to fit into.

    (3) If they do not, due to not enough material removed, then take a drill bit of the same diameter, and using the lowest speed setting on your drill, just touch up those indent holes in the dome..Check for fit and see if now your band dimple will fit snugly. This is more important than using the adhesive.

    (4) If you do use the adhesive, use a small amount in several places inside the band where the bands will fit up against the dome ceramics. 4 or 5 places on both top and bottom bands.

    (5) This will make it much easier to remove the bands if you need to in the future..

    Good luck...Char-Woody[p]

  • Char-Woody ,[p][p][p][p][p]
  • Char-WoodyChar-Woody Posts: 2,642
    Cajun Boy, Good morning. Something is really messed up here. There was no message, so I clicked on your handle "Cajun Boy" to send you a message via e.mail. When I did that, your message that didn't appear on the forum page, was in the header address of the e.mail form.
    This is weird...I will try to send you a e.mail as per your written instruction's that you tried to post..
    Cheers..
    C~W

Sign In or Register to comment.
Click here for Forum Use Guidelines.