Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
Welcome to the EGGhead Forum - a great place to visit and packed with tips and EGGspert advice! You can also join the conversation and get more information and amazing recipes by following Big Green Egg at:

Facebook  |  Twitter  |  Instagram  |  Pinterest  |  Youtube  |  Vimeo
Share your photos by tagging us and using the hashtag #EGGhead4Life.


In Atlanta? Come visit Big Green Egg headquarters, see our new showroom and check out the History of the EGG Museum and Culinary Center!  3786 DeKalb Technology Parkway, Atlanta, GA 30340.

Temp off on the Maverick?

tcryantcryan Posts: 0
edited September 2012 in EggHead Forum
First post, I've been lurking stealing ideas for my table, recipes and advice. To all who have contributed unknowingly, thank you...I'm having a blast with my LBGE. I just got the Maverick 732 for my birthday. Did some chicken thighs, raised grill. (stolen recipe from forum). Had the temp steady at 400, the temp probe was on the bottom rack and it was reading very close to dome temp for about 30 min of the cook. I did calibrate the dome thermometer when I first got my egg (stolen idea from forum). Then after the steady 30 min cook, the temp on my Mav shot to 450 degrees. I figured flare up and went to check. All was good, the dome read 375 and steady, the Mav climbed to 500. I tried resyncing and/or power on - off. Temp stayed steady at 500. Then as I'm writing this, I went out to pull the corn in husk off the grill...the Mav and the dome were exact. So confused. Is this a normal or did I get a lemon flavored Maverick? Thanks for any input.

Comments

  • EggdamEggdam Posts: 223
    Double check your Maverick in boiling water to make sure you are close to 212. That is a very big difference. I guess it could be possible that you were over a hot spot if you were cooking direct.
Sign In or Register to comment.
Click here for Forum Use Guidelines.