Big Green Egg - EGGhead Forum - The Ultimate Cooking Experience...
We’re feeling pretty super, how about you? The big game is fast approaching, and while we love football, we love an excuse to invite people over and cook even more! You too can cook like a champion with recipes from Dr. BBQ’s NFL Gameday Cookbook: Grilled Tuna Sandwiches from Seattle and Baked Brie from New England. Who’s going to win? You’ll have to cook both to find out.

The 17th Annual EGGtoberfest was amazing - here are the highlights Click Here

Maverick 732-- Junk

pineypiney Posts: 449
edited May 2012 in EggHead Forum
After reading several reviews I bought a Maverick 732. This unit is junk I have tried to use it twice with no luck.I have replaced batteries, turned unit off and on again, tried to re-sync and still does not work properly. I will contact the mfg. tomorrow. I personally think it is just more junk from China.
Lenoir, N.C.
·

Comments

  • bclarksiclebclarksicle Posts: 96
    sounds like a defective unit.  It happens.
    ·
  • travisstricktravisstrick Posts: 4,681
    I just ordered one. I'll report after I use it. Hopefully it works better.
    Be careful, man! I've got a beverage here.
    ·
  • ShiffShiff Posts: 1,218
    All I can say is that mine works great.   Syncs every time and the range is far better than the ET-73 I used to have.  I'm sure the manufacturer will swap you for a new one.
    Barry Lancaster, PA
    ·
  • pineypiney Posts: 449
    Shiff I feel the mfg will cover this it does have a 90 day warranty. It is sitting on my desk now reading food 106, bbq LLL. Last night it read all kinds of weird stuff. 
    Lenoir, N.C.
    ·
  • Mine works like a champ



    ·
  • gerhardkgerhardk Posts: 802
    edited May 2012
    sounds like a bad probe, switch were the meat probe and
     bbq probe plug into the sending unit, if the error message is now reversed I would think you have a defective probe.

    Gerhard
    ·
  • pineypiney Posts: 449
    gerhardk, I should have posted eariler that I was messing with this thing and did switch the probes and that seems to be the problem. Thanks for the input and I am sure we have found the problem, I will notify mfg Monday and see what they say but, I feel sure they will correct the issue.  
    Lenoir, N.C.
    ·
  • MikeGMikeG Posts: 174
    Lucky yours was junk from the start.  Mine didn't stop working until the Amazon return period was expired.  I'll not risk another.
    ·
  • pineypiney Posts: 449
    MikeG, I bought mine from someone on Ebay but I am going to mfg for help, I hope that works.
    Lenoir, N.C.
    ·
Sign In or Register to comment.